<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<link rel="pingback" href="http://www.mediageek.net/xmlrpc.php" />

<!-- Always force latest IE rendering engine (even in intranet) & Chrome Frame -->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />

<!--  Mobile viewport scale -->
<meta content="initial-scale=1.0, maximum-scale=1.0, user-scalable=yes" name="viewport"/>

<!-- This site is optimized with the Yoast WordPress SEO plugin v1.7.4 - https://yoast.com/wordpress/plugins/seo/ -->
<title>$13 Is Cheaper than a New Blu-Ray Player - mediageek</title>
<link rel="canonical" href="http://www.mediageek.net/2018/10/13-is-cheaper-than-a-new-blu-ray-player/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="$13 Is Cheaper than a New Blu-Ray Player - mediageek" />
<meta property="og:description" content="A number of years ago I bought a nice Yamaha Aventage Blu-Ray player. I bought this model because it&#8217;s a so-called &#8220;universal&#8221; disc player, able to deal with nearly any format in existence, including high-resolution SACDs and DVD-As. On top of that, reviews gave it very high marks for its audio quality for just playing &hellip;" />
<meta property="og:url" content="http://www.mediageek.net/2018/10/13-is-cheaper-than-a-new-blu-ray-player/" />
<meta property="og:site_name" content="mediageek" />
<meta property="article:tag" content="blu-ray,Blu-Ray player,CD,cd player,cleaning disc,compact disc" />
<meta property="article:section" content="audio" />
<meta property="article:published_time" content="2018-10-31T22:57:35+00:00" />
<meta property="og:image" content="http://www.mediageek.net/wp-content/uploads/2018/10/endust_262000_cd_dvd_blu_ray_game_console_lens_cleanr_925177.jpg" />
<meta name="twitter:card" content="summary"/>
<meta name="twitter:description" content="A number of years ago I bought a nice Yamaha Aventage Blu-Ray player. I bought this model because it&#8217;s a so-called &#8220;universal&#8221; disc player, able to deal with nearly any format in existence, including high-resolution SACDs and DVD-As. On top of that, reviews gave it very high marks for its audio quality for just playing [&hellip;]"/>
<meta name="twitter:title" content="$13 Is Cheaper than a New Blu-Ray Player - mediageek"/>
<meta name="twitter:site" content="@mediageek"/>
<meta name="twitter:domain" content="mediageek"/>
<meta name="twitter:image:src" content="http://www.mediageek.net/wp-content/uploads/2018/10/endust_262000_cd_dvd_blu_ray_game_console_lens_cleanr_925177.jpg"/>
<meta name="twitter:creator" content="@mediageek"/>
<!-- / Yoast WordPress SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="mediageek &raquo; Feed" href="http://www.mediageek.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="mediageek &raquo; Comments Feed" href="http://www.mediageek.net/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.mediageek.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<style type="text/css">
@media only screen and (min-width: 768px) {
body.three-col-middle-1000 #main-sidebar-container { width: 88.92%; }
body.three-col-middle-1000 #sidebar-alt { width: 7.85%; }
body.three-col-middle-1000 #main-sidebar-container #sidebar { width: 14.451192082771%; }
body.three-col-middle-1000 #main-sidebar-container #main { width: 81.927575348628%; }
}
</style>
<link rel='stylesheet' id='theme-stylesheet-css'  href='http://www.mediageek.net/wp-content/themes/canvas/style.css?ver=5.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='woo-layout-css'  href='http://www.mediageek.net/wp-content/themes/canvas/css/layout.css?ver=4.9.4' type='text/css' media='all' />
<!--[if lt IE 9]>
<link href="http://www.mediageek.net/wp-content/themes/canvas/css/non-responsive.css" rel="stylesheet" type="text/css" />
<style type="text/css">.col-full, #wrapper { width: 1000px; max-width: 1000px; } #inner-wrapper { padding: 0; } body.full-width #header, #nav-container, body.full-width #content, body.full-width #footer-widgets, body.full-width #footer { padding-left: 0; padding-right: 0; } body.fixed-mobile #top, body.fixed-mobile #header-container, body.fixed-mobile #footer-container, body.fixed-mobile #nav-container, body.fixed-mobile #footer-widgets-container { min-width: 1000px; padding: 0 1em; } body.full-width #content { width: auto; padding: 0 1em;}</style>
<![endif]-->
<script type='text/javascript' src='http://www.mediageek.net/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.mediageek.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.mediageek.net/wp-content/themes/canvas/includes/js/third-party.js?ver=4.9.4'></script>
<script type='text/javascript' src='http://www.mediageek.net/wp-content/themes/canvas/includes/js/modernizr.js?ver=2.6.2'></script>
<script type='text/javascript' src='http://www.mediageek.net/wp-content/themes/canvas/includes/js/general.js?ver=4.9.4'></script>

<!-- Adjust the website width -->
<style type="text/css">
	.col-full, #wrapper { max-width: 1000px !important; }
</style>

<link rel='https://api.w.org/' href='http://www.mediageek.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.mediageek.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.mediageek.net/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.4" />
<link rel='shortlink' href='http://www.mediageek.net/?p=2470' />
<link rel="alternate" type="application/json+oembed" href="http://www.mediageek.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.mediageek.net%2F2018%2F10%2F13-is-cheaper-than-a-new-blu-ray-player%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.mediageek.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.mediageek.net%2F2018%2F10%2F13-is-cheaper-than-a-new-blu-ray-player%2F&#038;format=xml" />

<!-- Theme version -->
<meta name="generator" content="Canvas 5.5.4" />
<meta name="generator" content="WooFramework 5.5.5" />

<!-- Custom CSS Styling -->
<style type="text/css">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</style>

<!-- Woo Shortcodes CSS -->
<link href="http://www.mediageek.net/wp-content/themes/canvas/functions/css/shortcodes.css" rel="stylesheet" type="text/css" />

<!-- Custom Stylesheet -->
<link href="http://www.mediageek.net/wp-content/themes/canvas/custom.css" rel="stylesheet" type="text/css" />

<!-- Google Webfonts -->
<link href="http://fonts.googleapis.com/css?family=Arvo:r,b,i,bi|Bitter:r,i,b" rel="stylesheet" type="text/css" />
</head>
<body class="post-template-default single single-post postid-2470 single-format-standard unknown alt-style-default three-col-middle width-1000 three-col-middle-1000 full-width full-header">
<div id="wrapper">

	<div id="inner-wrapper">

	    <!--#header-container-->
    <div id="header-container">
<h3 class="nav-toggle icon"><a href="#navigation">Navigation</a></h3>

	<header id="header" class="col-full">

		<div id="logo">
<span class="site-title"><a href="http://www.mediageek.net/">mediageek</a></span>
<span class="site-description">Paul Riismandel&#039;s internet home since Y2K.</span>
</div>

	</header>
	    </div><!--/#header-container-->
    <!--#nav-container-->
    <div id="nav-container">
<nav id="navigation" class="col-full" role="navigation">

	<section class="menus">

		<a href="http://www.mediageek.net" class="nav-home"><span>Home</span></a>

	<h3>Main Menu</h3><ul id="main-nav" class="nav fl"><li id="menu-item-2357" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-2357"><a href="http://www.mediageek.net/">Home</a></li>
<li id="menu-item-2355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2355"><a href="http://www.mediageek.net/about/">About Paul</a></li>
<li id="menu-item-2360" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2360"><a href="http://www.mediageek.net/archives/">mediageek Blog Archives</a></li>
<li id="menu-item-2431" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2431"><a href="http://mediageek365.tumblr.com">mediageek tumblr</a></li>
<li id="menu-item-2434" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2434"><a href="http://twitter.com/mediageek">twitter</a></li>
<li id="menu-item-2436" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2436"><a href="https://www.linkedin.com/in/paulriismandel">LinkedIn</a></li>
<li id="menu-item-2356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2356"><a href="http://www.mediageek.net/contact-2/">Contact</a></li>
</ul>	<ul class="rss fr">
						<li class="sub-rss"><a href="http://www.mediageek.net/feed/"></a></li>
			</ul>
	
	</section><!-- /.menus -->

	<a href="#top" class="nav-close"><span>Return to Content</span></a>

</nav>
    </div><!--/#nav-container-->
       
    <!-- #content Starts -->
	    <div id="content" class="col-full">
    
    	<div id="main-sidebar-container">    

            <!-- #main Starts -->
                        <section id="main">                       
<article class="post-2470 post type-post status-publish format-standard has-post-thumbnail hentry category-audio category-electronics tag-blu-ray tag-blu-ray-player tag-cd tag-cd-player tag-cleaning-disc tag-compact-disc">
<a href="http://www.mediageek.net/wp-content/uploads/2018/10/endust_262000_cd_dvd_blu_ray_game_console_lens_cleanr_925177.jpg" rel="lightbox" title="$13 Is Cheaper than a New Blu-Ray Player"><img src="http://www.mediageek.net/wp-content/uploads/2018/10/endust_262000_cd_dvd_blu_ray_game_console_lens_cleanr_925177-640x480.jpg" alt=""  width="640"  height="480"  class="woo-image thumbnail aligncenter" /></a>	<header>
	<h1 class="title">$13 Is Cheaper than a New Blu-Ray Player</h1>	</header>
<div class="post-meta"><span class="small">By</span> <span class="author vcard"><span class="fn"><a href="http://www.mediageek.net/author/paul/" title="Posts by Paul" rel="author">Paul</a></span></span> <span class="small">on</span> <abbr class="date time published" title="2018-10-31T22:57:35+0000">October 31, 2018</abbr>  <span class="small">in</span> <span class="categories"><a href="http://www.mediageek.net/category/audio/" title="View all items in audio">audio</a>, <a href="http://www.mediageek.net/category/electronics/" title="View all items in electronics">electronics</a></span>  </div>
	<section class="entry">
<p>A number of years ago I bought a nice <a href="https://hometheaterreview.com/yamaha-aventage-bd-a1010-3d-blu-ray-player-reviewed/" rel="noopener" target="_blank">Yamaha Aventage Blu-Ray player</a>. I bought this model because it&#8217;s a so-called &#8220;universal&#8221; disc player, able to deal with nearly any format in existence, including high-resolution <a href="https://en.wikipedia.org/wiki/Super_Audio_CD" rel="noopener" target="_blank">SACD</a>s and <a href="https://en.wikipedia.org/wiki/DVD-Audio" rel="noopener" target="_blank">DVD-A</a>s. On top of that, reviews gave it very high marks for its audio quality for just playing CDs.</p>
<p>Though my CD listening has decreased over the years as my <a href="http://www.radiosurvivor.com/2015/09/30/my-sonos-is-an-internet-radio/">Sonos</a> listening has increased, I still have hundreds of discs, many of them not available in a streaming format. So I was dismayed a couple of weeks ago when my wife reported that a favorite CD by <a href="https://pitchfork.com/reviews/albums/4805-salt/" rel="noopener" target="_blank">Arto Lindsay</a> wouldn&#8217;t play. She gave it a cleaning and we tried it in our office stereo, an <a href="https://nadelectronics.com/product/c-715-compact-music-system/" rel="noopener" target="_blank">NAD C715</a> compact stereo, and it played fine. But the Blu-Ray player wouldn&#8217;t even acknowledge it.</p>
<p>I&#8217;ve had a few situations in the past where my DVD player wouldn&#8217;t read some CDs, so I just chalked it up to these more sophisticated video machines being more sensitive. </p>
<p>But then a couple weeks later my wife reported that another disc, Variable Unit&#8217;s &#8220;<a href="https://www.discogs.com/Variable-Unit-Handbook-For-The-Apocalypse/release/3479934" rel="noopener" target="_blank">Handbook for the Apocalypse</a>&#8221; wouldn&#8217;t load either. Again, it played fine in the office stereo.</p>
<p>Now I was getting annoyed. Although the Blu-Ray player is about 8 years old, I wouldn&#8217;t expect it to be dying already. Especially because it doesn&#8217;t get used that much. </p>
<p>I started googling around to see if there were any specific problems reported for my particular model, and found nothing out there on message boards or on Yamaha&#8217;s support site. Not experiencing any problems with DVDs or Blu-Rays, I wondered if maybe the problem is reserved for CDs, so I also started looking for a new CD player to supplement it, or a new universal Blu-Ray player to replace it. </p>
<p>As you might guess, there are fewer component CD players available these days. If I were to go that route I wanted something more compact that might slide in to a smaller shelf in my TV stand. There are even fewer new models that meet that requirement, and two I found cost at least $400. Ouch.</p>
<p>Feeling a little frustrated, but not defeated, I figured I could just rip the CDs that won&#8217;t play right and put them on my media server. But that&#8217;s just more effort, and still annoying.</p>
<p>Then, somehow I happened upon discussions of general Blu-Ray player problems, discs of all sort not loading, even when clean or relatively new. A consistent solution was to use a cleaning disc.</p>
<p>I remember having a laser cleaning disc for my 1987 vintage CD player back in the day, that only ever got used a few times. And that experience left me with the impression that such a remedy wasn&#8217;t generally necessary.</p>
<p>Blu-Ray players – and DVD players to some extent – are different, I learned. There are two factors at play. First, the pickup lenses are very different since they have to deal with three different wavelengths of light, and Blu-Ray is a much tinier wavelength than CDs (blue vs. red). Second, almost all Blu-Ray players, mine included, have fans, which blow in dust, along with air, making them much more susceptible to contamination.</p>
<p>Thus I set about finding a Blu-Ray cleaning disc. Along the way I was cautioned that you need to buy the proper kind of disc – that a DVD cleaner is not suitable for a Blu-Ray player, and vice-versa. This is largely due to the fact that the laser lens sits at different distances from the disc in each kind of player. </p>
<p>In the end I ordered an <a href="http://www.endustforelectronics.com/11452.php" rel="noopener" target="_blank">Endust branded Blu-Ray lens cleaner</a> for $13. It arrived today.</p>
<p>Before giving it a go I gave the Arto Lindsay disc another try. Just before ordering the cleaning disc I made multiple attempts to play that disc, ejecting and trying to play it several times. Once it worked, but it was not reliable. Again, today, it wouldn&#8217;t even read.</p>
<p>So I ran the cleaning disc procedure, which takes less than a minute, then loaded in Arto Lindsay. It played right away. Next went in the Variable Unit disc. Boom, success. </p>
<p>In our contemporary world of irreparable and disposable electronics I consider this to be a small victory. $13 is a small price to pay not to replace my disc player. </p>
	</section><!-- /.entry -->
	<div class="fix"></div>
		<aside id="connect">
		<h3>Subscribe and Follow</h3>

		<div class="col-left">
			<p>Subscribe to the RSS feed or follow me on Twitter.</p>

			
			
						<div class="social">
		   				   		<a href="http://www.mediageek.net/feed/" class="subscribe" title="RSS"></a>

		   				   		<a target="_blank" href="http://twitter.com/mediageek" class="twitter" title="Twitter"></a>

		   					</div>
			
		</div><!-- col-left -->

				<div class="related-posts col-right">
			<h4>Related Posts:</h4>
			<div class="woo-sc-related-posts">
<ul>
<li class="post-id-2462">

<a href="http://www.mediageek.net/2018/10/to-make-sound-art-you-just-need-a-recorder/" title="To Make Sound Art You Just Need a Recorder" class="related-title"><span>To Make Sound Art You Just Need a Recorder</span></a>
</li>
<li class="post-id-2261">

<a href="http://www.mediageek.net/2010/12/for-concert-audio-the-sanyo-xacti-beats-the-sony-nex-5-hands-down/" title="For concert audio the Sanyo Xacti beats the Sony NEX-5, hands down" class="related-title"><span>For concert audio the Sanyo Xacti beats the Sony NEX-5, hands down</span></a>
</li>
<li class="post-id-2185">

<a href="http://www.mediageek.net/2010/08/the-best-camcorder-is-the-one-you-have-with-you/" title="The best camcorder is the one you have with you" class="related-title"><span>The best camcorder is the one you have with you</span></a>
</li>
<li class="post-id-2122">

<a href="http://www.mediageek.net/2010/05/audio-audiophiles-and-the-aesthetic-experience-of-medium/" title="Audio, Audiophiles and the Aesthetic Experience of Medium" class="related-title"><span>Audio, Audiophiles and the Aesthetic Experience of Medium</span></a>
</li>
<li class="post-id-2061">

<a href="http://www.mediageek.net/2010/01/turntables-at-ces-still-mostly-cheap-plastic/" title="Turntables at CES: Still Mostly Cheap Plastic" class="related-title"><span>Turntables at CES: Still Mostly Cheap Plastic</span></a>
</li>
</ul>
<div class="fix"></div><!--/.fix-->
</div><!--/.woo-sc-related-posts-->		</div><!-- col-right -->
		
        <div class="fix"></div>
	</aside>
	<div class="post-utility"><p class="tags"><i class="icon-tag"></i> <a href="http://www.mediageek.net/tag/blu-ray/" rel="tag">blu-ray</a>, <a href="http://www.mediageek.net/tag/blu-ray-player/" rel="tag">Blu-Ray player</a>, <a href="http://www.mediageek.net/tag/cd/" rel="tag">CD</a>, <a href="http://www.mediageek.net/tag/cd-player/" rel="tag">cd player</a>, <a href="http://www.mediageek.net/tag/cleaning-disc/" rel="tag">cleaning disc</a>, <a href="http://www.mediageek.net/tag/compact-disc/" rel="tag">compact disc</a></p> </div>
</article><!-- /.post -->
	        <div class="post-entries">
	            <div class="nav-prev fl"><a href="http://www.mediageek.net/2018/10/weird-dreams/" rel="prev"><i class="icon-angle-left"></i> Weird Dreams</a></div>
	            <div class="nav-next fr"></div>
	            <div class="fix"></div>
	        </div>

		<div id="comments"><h5 class="nocomments">Comments are closed.</h5></div>     
            </section><!-- /#main -->
                
            <aside id="sidebar">
<div id="woo_search-2" class="widget widget_woo_search"><h3>Search</h3><div class="search_main">
    <form method="get" class="searchform" action="http://www.mediageek.net/" >
        <input type="text" class="field s" name="s" value="Search..." onfocus="if (this.value == 'Search...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search...';}" />
                <button type="submit" class="icon-search submit" name="submit" value="Search"></button>
    </form>    
    <div class="fix"></div>
</div>
</div></aside><!-- /#sidebar -->

		</div><!-- /#main-sidebar-container -->         

		
    </div><!-- /#content -->
	
	<footer id="footer" class="col-full">

		
		<div id="copyright" class="col-left">
			<p>&copy; 2018 mediageek. All Rights Reserved. </p>		</div>

		<div id="credit" class="col-right">
			<p>Powered by <a href="http://wordpress.org/" title="WordPress">WordPress</a>. Designed by <a href="http://www.woothemes.com/" title="WooThemes"><img src="http://www.mediageek.net/wp-content/themes/canvas/images/woothemes.png" width="74" height="19" alt="Woo Themes" /></a></p>		</div>

	</footer>

	
	</div><!-- /#inner-wrapper -->

</div><!-- /#wrapper -->

<div class="fix"></div><!--/.fix-->

<script type='text/javascript' src='http://www.mediageek.net/wp-includes/js/comment-reply.min.js?ver=4.9.4'></script>
<script type='text/javascript' src='http://www.mediageek.net/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
</body>
</html>